summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohannes Hofmann <johannes.hofmann@gmx.de>2005-04-07 15:02:09 +0000
committerJohannes Hofmann <johannes.hofmann@gmx.de>2005-04-07 15:02:09 +0000
commit2942bf5e84a4eebf660dac3906025342a4722c18 (patch)
treeac5aaeb0210cd3e2135585fa2d3fb34eebfce1da /configure.ac
parent57c758b640c7eba7fc8271722e51a19ef7da1d0a (diff)
add X11 detection
add X11 detection
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e5f7f04..950a071 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,5 +38,8 @@ AC_ARG_WITH([fltk-dir], AS_HELP_STRING([--with-fltk-dir=DIR], [fltk is installed
AC_CHECK_HEADERS([FL/Fl.H], [], [echo "Error: FL/Fl.H not found. Try './configure --with-fltk-dir=DIR'"; exit 1;])
AC_CHECK_LIB([fltk], [open], [], [echo "Error: libfltk.so not found. Try './configure --with-fltk-dir=DIR'"; exit 1;])
+# Check for X11
+AC_CHECK_LIB([X11], [open], [], [echo "Error: libX11.so not found."; exit 1;])
+
AC_CONFIG_FILES([Makefile src/Makefile])
AC_OUTPUT