summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohannes Hofmann <johannes.hofmann@gmx.de>2005-05-08 18:49:46 +0000
committerJohannes Hofmann <johannes.hofmann@gmx.de>2005-05-08 18:49:46 +0000
commit685bae302ab0b590b57be2375168a9e06fe9fed7 (patch)
tree5545d628ec02c25670f9ab17a08e6760ae9e2e8a /configure.ac
parent7968b87758428821c38936cf10affb356d3ad940 (diff)
autoconf/automake
autoconf/automake
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac54
1 files changed, 54 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..513aae9
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,54 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(gipfel, 0.0.1, Johannes.Hofmann@gmx.de)
+AM_INIT_AUTOMAKE
+AC_CONFIG_SRCDIR([src/Panorama.H])
+AC_CONFIG_HEADER(config.h)
+
+CPPFLAGS="-I/usr/local/include"
+CXXFLAGS="-I/usr/local/include"
+
+# Checks for programs.
+AC_PROG_CXX
+
+AC_LANG_CPLUSPLUS
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_HEADER_SYS_WAIT
+AC_CHECK_HEADERS([fcntl.h stdlib.h string.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_CONST
+AC_TYPE_OFF_T
+AC_TYPE_PID_T
+
+# Checks for library functions.
+AC_FUNC_FORK
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_TYPE_SIGNAL
+AC_CHECK_FUNCS([dup2 setenv strchr strdup strrchr strstr])
+
+# Check for fltk
+AC_PATH_PROG(FLTKCONFIG,fltk-config)
+if test "x$FLTKCONFIG" = x; then
+ echo "fltk-config not found"
+ exit 1
+fi
+
+CXXFLAGS="`$FLTKCONFIG --use-images --cflags` $CXXFLAGS"
+LIBS="`$FLTKCONFIG --use-images --ldflags` $LIBS"
+
+
+# Check for ccmath
+AC_CHECK_HEADERS([ccmath.h], [], [echo "Error: ccmath.h not found."; exit 1;])
+AC_CHECK_LIB([ccm], [open], [], [echo "Error: ccmath.so not found."; exit 1;])
+
+AC_CONFIG_FILES([Makefile src/Makefile])
+AC_OUTPUT