summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohannes Hofmann <Johannes.Hofmann@gmx.de>2009-04-07 14:30:26 +0200
committerJohannes Hofmann <Johannes.Hofmann@gmx.de>2009-04-07 14:30:26 +0200
commit8d2d73759dfe0c193c29b7e1f0b90a0873c3b9e7 (patch)
treee6d3d610c5eb88e1d1edb06998275e9241ea1206 /configure.ac
parent73b38c69e3dadacda33a2df00b3b5f62bc895256 (diff)
switch ImageMetadata to exiv2 (mostly by Konrad Golling)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index de7e818..e9cf00e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,5 +60,9 @@ LIBS="`$GSLCONFIG --libs` $LIBS"
AC_CHECK_HEADERS([tiffio.h], [], [echo "Error: tiffio.h not found."; exit 1;])
AC_CHECK_LIB([tiff], [TIFFOpen], [], [echo "Error: libtiff.so not found."; exit 1;])
+# Check for exiv2
+AC_CHECK_HEADERS([exiv2/exif.hpp], [], [echo "Error: exiv2/exif.hpp not found."; exit 1;])
+LIBS="$LIBS -lexiv2"
+
AC_CONFIG_FILES([Makefile src/Makefile])
AC_OUTPUT